top of page


Pubblico·48 membri

Qucs - A Tutorial - SourceForge ((HOT))

Until now there is no or little user documentation available. The Qucs application has an integrated help system giving the user useful but yet limited help with the program. However, a useful beginners tutorial can be found here (pdf). We are searching for people who want to support the project by creating more documentation. The internal help system is also multi-lingual, thus translations into languages other than English, German, French and Spanish have to be done. If you are interested then feel free to write a email to: contact. It is planned to have user manuals consisting of

Qucs - A Tutorial - SourceForge

Download Zip:

If I take out the parameter simulation, and hard code in values for tsweep I get the values given in the tutorial at the various parameter values. So there must be something wrong with the parameter simulation.

I deviated a little from the tutorial in that I did not make subcircuits, I only made the schematic, made an icon from it and put into the test scheme. So I didn't have to go through the parameter passing.

Also, if you look at the graph in the tutorial, you will see that your results are completely different than that given in the tutorial. The graph in the tutorial shows a dip around 30, yours does not!

Problem solved! The attachment shows the results. I put in a resistor divider into the schematic, the same as in the tutorial and it worked the same as in the tutorial, but not the subcircuit! When I assigned the tsweep to tsweep parameter of the subcircuit, that also worked! Looks like the parameter sweep can't access the inner workings of the subcircuit where tsweep was assigned to the temperature!

I put this example from figure 5 into Qucs, ran a simulation, and looked at the netlist (F5). I double checked the code several times, looks OK. The netlist (F5) does not show the updated R and C values. The graphs are not even close! I need help getting this tutorial to work! This post will not allow me to attach a file to this post, so I will self reply to my own post where I can add a single attachment. I have never been able to add attachments to my original posts! Please view the following 3 self replies to see what I'm talking about.

More information on this problem: I changed the equation to hard wire in the values for R, C, R3_eval, and and R4_eval , put in the values from the tutorial netlist, and ran another simulation. The graphs were still screwed up, so I guess there is something wrong in the schematic. Yet the schematic is straight out of the tutorial!

In this tuorial example, after inputting the schematic and setting up the scheme, I get errors about an undefined V1 parameter in the equation. V1 is the source. This is straight out of the tutorial, but I cannot find anything wrong with what I did. The related attachments are contained in the following two replies.

Problem solved! There is an error in this tutorial, and an error of ommission as well! In the EDD equation block, V1 should have been V1.v for all the parameters in this equation, not as shown in the tutorial. The graphs still looked like crap so I set the transit points to 100 and all looked well. This is an error of ommission, make the chart points visable in the tutorial for the user to see. This is not the first time that I have found a problem with the tutorials, so be carefull when trying to get these things to work per tutorial.

In the Qucs tutorial in figure 20 there is an EDD and a test circuit. The parameters for the EDD contain V1 in the equation. This doesn't compile unless you substitute V1.v for these parametes! This document is made by Mike Brinson and is found in the help getting started selection of Qucs.

using V1 in an EDD equation must work, as described above.There is a ton of documents, PDF files and web pages for Qucs, please provide the PDF file name or the web page URL for the tutorial you are referring to.

um, I created a project according to the tutorial description and if worked as expected, using "V1" in the EDD component equation.Enclose is a zip file with the project, please check w.r.t. your circuit.In general you may also include your failing project/schematic, will probably make it easier to understand what's wrong.

This is the zip files for two projects. The figure 20 and test schematics work. In this one I had to change VI to V1.V. The later being the input source supply. Everything works with the charts showing exactly what is shown in the tutorial! The project that you included is quite different than what I'm dealing with in the tutorial: its an inductor. In figure 23 of my project I tried a different approach. Because the I and Q properties all contained V1, which is not defined, I added into the equation the line:V1=PAnode-PCathode, defining V1, since these are connected to the source and ground of the EDD diode. No good. So I triedV1=PAnode.V-PCathode.V. Still no good! But figure 20 does! I'm betting that if I replace V1 with Vs1.V, similar to what I did in figure 20, this will work. But that would defeat the purpose of having the diode with input parameters which were never used in these examples.

In the command prompt, I've changed the current directory to the one in which qucsator.exe is stored, and I've moved my netlist .net file,, into that directory as well. However, when I run the ismple command qucsator

I wish you the best of luck with this textmode tutorial. The command line given above does work. However, the Octave part following, loadQucsDataSet etc. is, for me in windows, AFU! Octave can't find the plotting functions, and there is little help from Octave about how to fix it. Then the rest of the tutorial goes into using Python!! I would give this document a 0 out of 10! I got so frustrated with this tutorial I uninstalled Octave, and deleted the document! The only reason that I looked at this tutorial in the first place, was to see if it had answers to my question of how to use a netlist file directly in Qucs, instead of creating a schematic, then Qucs creating a netlist file, and then running a simulation. It seemed like an easy matter to use a netlist file with Qucs directly to make a simulation. But no, it doesn't seem possible. Certainly nobody in this forum relied to my posts on the subject. I am very disappointed with this part of Qucs. And to make matters worst, the support from this forum is, sadly, lacking. 90% of my posts are completely ignored. And a good forum is needed to support a tool like Qucs. I've joined quite a few other forums, Eclipse for example, and I have never had to wait for more than a day to receive a reply. Not so with this forum.

The command line conversion program tool is used by the GUI to import and export datasets, netlists and schematics from and to other CAD/EDA software. The supported file formats as well as usage information can be found on the manpage of qucsconv.

Additionally, the GUI can steer other EDA tools. Analog and mixed simulations can be performed by simulators that read the qucsator netlist format. For purely digital simulations (via VHDL) the program FreeHDL [2] or Icarus-Verilog can be used. For circuit optimization (minimization of a cost function), ASCO [3] may be invoked.

I have compiled qucs-s 0.23 on opensuse leap 15.3. Compilation went fine. All runs fine. In setting up the initial tutorial schematic (voltage divider), all goes well. Simulation seems to work. Simulation dialogue says:

But on the results page, after selecing "Tabular" , a table opens but there are no result shown for selection as is presented in the tutorial. All fields are blank. If I enter a name such as "divider" and click that to the right side, it still has no value associated with "divider".

In this tutorial there is a section using Octave code to make a plot from a dataset. loglog() and loadQucsDataSet() functions are to be used. Looking up these two functions in Octave I find the loglog() function, but nowhere can I find the function loadQucsDataSet(). It is not part of Octave at all! How can a tutorial with such an obvious error be part of the Qucs documentation?

I thought it would be rather obvious that loadQucsDataSet is an Octave file shipped with Qucs, and not a stndard Octave function. If the tutorial has a problem, it is that the location of this file is not explained.

Well, I looked into the QQucs installation directories, starting with the bin directory and then looking at all the other installed directories and found no such loadQucsDataSet executable file! And I have the latest version of Qucs installed. So I guess the file didn't get shipped with Qucs! Unless I'm a bit blind and can't see it. Even if you are right about these files, I find this tutorial more than a little strange in that I am supposed to open a DOS window and then need to execute two different exe files, contained in two very different directories: one in Octave, and the other one in Qucs. So, if I remember my DOS days correctly, I would have to set 2 seperate path variables: one for each exe file. Then I could go to the data file, in it's own directory, and use these two exes. It would have been pretty simple if one could just use Octave to get these steps done, but that doesn't seem to be the case.

At page 3 of the tutorial, in the Prerequisites section, it says "The m-files located under qucs/qucs/octave"; the path is starting from the Qucs source code base directory.When Qucs is installed the files are in share/qucs/octave . There you'll find the file loadQucsDataSet.m and others. You'll need to incude that directory in the Octave path so it can find the scripts or simply copy them in your work directory.

Well, I hate to say it, but in my Qucs install there is no qucs/qucs/octave directory! I also did a windows search for this file and it came up empty! I must say that when I downloaded the newest version of Qucs to get rid of some problems with the older version, I noticed that all I got from the download was a zip file. This file, when unzipped, contained no installer or uninstaller utility. Good downloads should, to say the very least, contain an install utility! All this download contained was the complete set of Qucs project directories which I copied and pasted into the originally installed version, which if I am remembering correctly, did contain an installer. But that was so long ago I cannot say that for sure. I'm still wondering how to get a download for the newest Qucs that contains an installer! Then I could uninstall this version and try to install the new version. 041b061a72


Vuoi giocare ma ti manca l'avversario? Un giocatore ha avuto...
bottom of page